tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cost...@covalent.net>
Subject RE: cvs commit: jakarta-tomcat-connectors/coyote/src/java/org/apache/coyote/tomcat4 CoyoteConnector.java CoyoteProcessor.java
Date Fri, 01 Mar 2002 01:36:46 GMT
On Thu, 28 Feb 2002, GOMEZ Henri wrote:

> Do you think coyote could be ever used with Tomcat 3.3 ?
> ie: works with JDK 1.1, support TC 3.3 via modules.... 

Again: tomcat3.3 _doesn't_ require all modules to support
JDK1.1 ! The only requirement is to have the basic 
functionality ( of a servlet container ) working on JDK1.1,
and we already have that.

There are quite a few optional modules in 3.3 that require
1.2 - sandbox, thread loader, etc. As long as the 
core is JDK1.1 compatible, things are going to be ok.

> JK/JK2 are available for both TC 3.3/4.x, it could be fine to
> have also a common HTTP connector for them and coyote seems
> to be the perfect candidate :)

Well, we already have 4 HTTP/1.1 connectors for 3.3 :-) 
But I agree it would be good if Coyote would share more with
jk - right now they use the low level stuff, but it would
be trivial to integrate them a bit more and share the
same connector ( the Request impl. - which will require 
quite a bit of work to optimize for 4.x ). 

Costin


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message