tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cost...@covalent.net>
Subject RE: Rename jK2 to mod_jk2 ?
Date Mon, 18 Feb 2002 19:36:06 GMT
On Mon, 18 Feb 2002, GOMEZ Henri wrote:

> Any objection to see JkMount renamed to Jk2Mount in mod_jk2 
> and in general all Directive subject to collisions with the 
> original mod_jk...

I have one :-)

If we change JkMount, I would rather change it into nothing ( i.e. 
get rid of it ). It should be in just for backward compatibility
with jk1.

I like this aproach to backward compatibility - i.e. including
both the old code and the new code, sort of 'perfect' backward
compat. 

Instead of JkMount we should use either 
 <Location path="/foo" >
   JkWebapp worker ajp13
 </Location>

or jkurimap.properties - which is already used for IIS and has 
more 'potential' to support dynamic updates to the config ( without
apache restart ). 

This way we'll have a consistent server-independent config
( properties ) and a server-optimized config ( location 
uses the internal mapper which is more optimized and 
we avoid duplicating the mapping ).


Costin


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message