tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "GOMEZ Henri" <hgo...@slib.fr>
Subject RE: Rename jK2 to mod_jk2 ?
Date Tue, 19 Feb 2002 09:17:23 GMT
So JkMount in Jk2 will point to NOP ?

-
Henri Gomez                 ___[_]____
EMAIL : hgomez@slib.fr        (. .)                     
PGP KEY : 697ECEDD    ...oOOo..(_)..oOOo...
PGP Fingerprint : 9DF8 1EA8 ED53 2F39 DC9B 904A 364F 80E6 



>-----Original Message-----
>From: costinm@covalent.net [mailto:costinm@covalent.net]
>Sent: Monday, February 18, 2002 8:36 PM
>To: Tomcat Developers List
>Subject: RE: Rename jK2 to mod_jk2 ?
>
>
>On Mon, 18 Feb 2002, GOMEZ Henri wrote:
>
>> Any objection to see JkMount renamed to Jk2Mount in mod_jk2 
>> and in general all Directive subject to collisions with the 
>> original mod_jk...
>
>I have one :-)
>
>If we change JkMount, I would rather change it into nothing ( i.e. 
>get rid of it ). It should be in just for backward compatibility
>with jk1.
>
>I like this aproach to backward compatibility - i.e. including
>both the old code and the new code, sort of 'perfect' backward
>compat. 
>
>Instead of JkMount we should use either 
> <Location path="/foo" >
>   JkWebapp worker ajp13
> </Location>
>
>or jkurimap.properties - which is already used for IIS and has 
>more 'potential' to support dynamic updates to the config ( without
>apache restart ). 
>
>This way we'll have a consistent server-independent config
>( properties ) and a server-optimized config ( location 
>uses the internal mapper which is more optimized and 
>we avoid duplicating the mapping ).
>
>
>Costin
>
>
>--
>To unsubscribe, e-mail:   
<mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message