tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: Native Connector problems
Date Wed, 13 Feb 2002 11:18:12 GMT
Remy Maucherat wrote:
> 
> > The problem is that the default cache size is one and in the ajp_init
> > function
> > in jk_ajp_common.c we return from inside of an if when we initialize
> > the cache
> > so the secrect member of the structure never gets initialized.  This
> > caused
> > some GPFs in certain cases on some of my builds.
> >
> > I've checked in the fix.  All I did was move the line that initializes
> > secret up above
> > the if statement.
> >
> > Remy, would it be possible to relabel jk_ajp_common.c
> > rev. 1.24 as the rev for tomcat_402?  I've built and tested this fix on
> > NetWare
> > and the resolved my GPFs and bad behavior talking to older
> > installations
> > of Tomcat (i.e. 3.3).  I was able to use the same module to talk to
> > Tomcat 4.0.2 and Tomcat 3.3 from the same instance of the web server.
> > I love it when a plan comes together :-)
> 
> I've retagged the file.

Nice... But the tarballs should be redone, should n't they?
Then how to know that a 4.0.2 tarballs (connectors) is a good one?
I would have retagged jakarta-tomcat-connectors as tomcat_402_01 and will
rebuild the tarballs as jakarta-tomcat-connectors-4.0.2-01-src.*

Any comments?


> 
> Thanks,
> Remy
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message