tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: Client Certificates working with mod_jk but not with mod_webapp
Date Fri, 01 Feb 2002 14:44:53 GMT
Markus Maeder wrote:
> 
> Hi
> 
> Some days ago I posted following message in tomcat-user and had one reply
> stating he is having the same problem.
> 
> I'd like to fix this problem. Is there somebody already working on this? If not,
> which source should I get to track down the problem?

What is the problem? It works well on my tests, try the test application I have
attached to the mail..

> 
> Markus
> 
> My message in tomcat-user:
> --- Markus Maeder <mmaeder@oase.ch> wrote:
> > Hi!
> >
> > I was playing around with Tomcat 4.0.1 and couldn't
> > get the client certificates
> > from apache through mod_webapp. So I tried Tomcat
> > 4.0.2 b2 and the build from
> > January 27. I even compiled a new mod_webapp
> > (1.0.2-tc402).
> >
> > Then I tried ajp13 and mod_jk. This is working fine
> > after I changed my code
> > (working in Tomcat 3.2x) from
> >
> > String certAttribute =
> > "javax.servlet.request.X509Certificate";
> > X509Certificate certificate =
> >
> (java.security.cert.X509Certificate)request.getAttribute(certAttribute);
> >
> > To version for Tomcat 4:
> > String certAttribute =
> > "javax.servlet.request.X509Certificate";
> > X509Certificate certificate[] =
> >
> (java.security.cert.X509Certificate[])request.getAttribute(certAttribute);
> >
> > As I think I missed something in the configuration
> > of mod_webapp, I wonder, if
> > somebody has a working configuration for getting
> > client certificates with
> > mod_webapp, apache 1.3 and mod_ssl.
> >
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>
Mime
View raw message