tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <>
Subject Re: Tomcat 4.1-dev Host unpackWARs not working
Date Thu, 28 Feb 2002 16:26:55 GMT

On Thu, 28 Feb 2002, Glenn Nielsen wrote:

> Date: Thu, 28 Feb 2002 09:18:39 -0600
> From: Glenn Nielsen <>
> Reply-To: Tomcat Developers List <>
> To:
> Subject: Tomcat 4.1-dev Host unpackWARs not working
> The Host attribute unpackWARs="true" is not working in the Tomcat 4 HEAD CVS
> version.
> I think it is due to the following at line 232 in
> If you turn debug on you will see that a war file in the webapps directory
> is deployed using a jar:file URL.
>         // Expand a WAR archive into an unpacked directory if needed
>         // NOTE:  If the user supplies a "jar:file:" URL, assume that
>         // they do not want WAR expansion even if unpackWARs is set
>         if (host.isUnpackWARs() && !url.startsWith("jar:file:")) {
> What is the reason for making the above assumption?
> If there is a valid reason for doing this, it should be documented
> that unpackWARs="true" works except when ...

This comment is embedded inside the install() method, which accepts a URL
to either a WAR or a directory.  Since the person doing the deployment
(typically using the manager webapp) consciously made a choice to send one
or the other, it's not a good idea for the container to second guess that

I will update the docs on unpackWARs to note that it only applies to
auto-deployed apps (from the appBase directory) at startup time.

> Regards,
> Glenn


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message