tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 6438] New: - Problem with JARed taglibs
Date Wed, 13 Feb 2002 20:59:48 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=6438>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=6438

Problem with JARed taglibs

           Summary: Problem with JARed taglibs
           Product: Tomcat 4
           Version: 4.0.2 Final
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: craiga@mindwrap.com


I just downloaded the new Tomcat 4.0.2 and I had trouble getting my web 
application to load successfully.  ${TOMCAT}/logs/catalina.out shows the 
following lines:

 Apache Tomcat/4.0.2
 PARSE error at line 1 column 1
 org.xml.sax.SAXParseException: The markup in the document preceding the root 
element must be well-formed.
 Starting service Tomcat-Apache
 Apache Tomcat/4.0.2
 PARSE error at line 1 column 1
 org.xml.sax.SAXParseException: The markup in the document preceding the root 
element must be well-formed.

This would seem to indicate that some XML file is bad -- the messages 
gives no clue to which file has the problem.   

After trying a few things I found that if I comment the taglib definition lines 
from my web.xml file the error message goes away.

Next, I extracted the TLD file from the JAR that contains my tag library, and
modified web.xml to point to the TLD iteslf.  That fixed the problem.

The JSP specifiecation (JSP.7.3.2) says: "The TLD resource path ... should
resolve to a TLD file directly, OR TO A JAR FILE [emphisis mine] that has a TLD
file at location META-INF/taglib.tld."  

It seems that the latter does not work well in Tomcat 4.0.2.  I guess the code
that looks for the TLD is not correctly handling JARs.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message