tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 6199] New: - resetBuffer doesn't seem to reset buffer
Date Sun, 03 Feb 2002 01:46:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=6199>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=6199

resetBuffer doesn't seem to reset buffer

           Summary: resetBuffer doesn't seem to reset buffer
           Product: Tomcat 4
           Version: 4.0.2 Beta 2
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Jasper
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: netchris3@quickstream.com


My reading of the 2.3 servlet specification description of 
ServletResponse.resetBuffer() (in section 5.1) is that the following JSP file:

---begin jsp
hello
<% response.resetBuffer(); %>
bye!
---end jsp

should produce (assuming the buffer has not been committed) just "bye!" when 
the page is retrieved.  Instead I get "hello bye!".  I tried this on 4.0.1 
final and 4.0.2 beta 2, both with jdk1.3.1.

Perhaps I'm just misreading the specification though.  Thanks.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message