tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anil Bhagawat" <anilb_...@hotmail.com>
Subject Problem while using JNI
Date Wed, 30 Jan 2002 01:14:17 GMT
Hi,

I have been trying to use JNI on Win2K using tomcat 4.0. I am running into a 
problem.

I keep getting UnSatisfiedLinkError exception. This doesn't happen when I 
execute the JNI from a sample JAVA application. I have placed the DLL under 
\winnt\system32 directory. The DLL is a C++ COM DLL compiled using MS Visual 
C++ 6.0. I tried using a C++ (no COM) DLL and a C DLL but no success.

I tried creating just a simple function that doesn't accept any parameters & 
doesn't return any value. But, still it doesn't work. So, the problem is 
unlikely to have with the param types etc.

I tried this on several versions of Tomcat but no success. I suspect this 
has to do something with Tomcat configuration (security ??)

Has anyone seen this problem before ? I would appreciate any help on this 
issue.

thanks

- Anil

_________________________________________________________________
MSN Photos is the easiest way to share and print your photos: 
http://photos.msn.com/support/worldwide.aspx


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message