tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 5974] - using Java code with quotes in attribute-value of tag
Date Tue, 29 Jan 2002 09:20:22 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5974>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5974

using Java code with quotes in attribute-value of tag

dvbaar@ferranti.be changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|VERIFIED                    |REOPENED
         Resolution|INVALID                     |



------- Additional Comments From dvbaar@ferranti.be  2002-01-29 09:20 -------
Can you please explain why the parser accepts the syntax in a tag without 
ending-tag 

<dvb:Tab select="<%= b?"yes":"no" %>" />

and not in one with ending-tag

<dvb:Tab select="<%= b?"yes":"no" %>"> Groups</dvb:Tab>

In the light of your remark about the JSP spec, this is not a bug. But then it 
IS a bug for an attribute-value in a tag without ending-tag!

Besides, I've been using the above syntax (without escaping) since the 
beginning, so I'm wondering, is this a change in the specification from JSP 1.1 
to 1.2?

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message