tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: TC 3.3.3 with Apache stack space error
Date Mon, 07 Jan 2002 22:53:05 GMT
There is a problem with 3.3.1 prior to about 12/31 (reported as bug 5390,
reopened) that could be this one.

I'm in the process of moving the StreamHandlerFactory into a module (where
it really belongs), but haven't finished testing it yet.
----- Original Message -----
From: "Ray Pitmon" <rp@digitalcyclone.com>
To: <tomcat-dev@jakarta.apache.org>
Sent: Monday, January 07, 2002 1:12 PM
Subject: Re: TC 3.3.3 with Apache stack space error


> Originally sent to tomcat-user, but here may be a better place for this.
>
> Why do I have to start java with -Xms400m -Xmx500m to get it to compile
> JSP pages?
>
> (see below for a better description of the problem)
>
> Ok, that works.  I tried all sorts of different values less than that,
> but -Xms needed to be 400 to get it to work.
>
> That doesn't make alot of sense to me.
> My tomcat is using 32 megs of RAM now.
>
> Why in the world would I have to specify that it use 400-500 megs?
>
> Is this a bug?
>
> thx,
>
> -Ray
>
>
>
>
> On Mon, 2002-01-07 at 10:27, Renato wrote:
> > Try to put something like -Xms400m -Xmx500m on TOMCAT_OPTS of
> tomcat.sh in
> > the $TOMCAT_HOME/bin directory.
> >
> >
> > On 07 Jan 2002 12:08:44 -0600, Ray Pitmon <rp@digitalcyclone.com>
> escreveu :
> >
> > >
> > >
> > > Hi,
> > >
> > > I have many machines running older versions of tomcat(3.2.x), but
> now I
> > > am setting up a new one, with 3.3.1, and I get this error whenever I
> try
> > > to hit a JSP:
> > >
> > > 2002-01-07 12:41:21 - Ctx() : compile error: req=R(  + /index.jsp +
> > > null) - org.apache.jasper.JasperException: Unable to compile The
> > > compiler has run out of stack space.  Consider using the
> > > "-J-oss<number>" command line option to increase the memory
> allocated
> > > for the Java stack.
> > >
> > >
> > > I am using the following:
> > > tomcat-mod-3.3-1 rpm
> > > tomcat-3.3-3 rpm
> > > apache 1.3.20-16 rpm
> > > IBM 1.3.0 JDK
> > >
> > > all on redhat 7.2.  It gives the same error whether thru apache or
> > > directly to tomcat's webserver.
> > >
> > >
> > > thx for any ideas anyone has...
> > >
> > > -Ray
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message