tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Graff" <ph...@mindspring.com>
Subject Re: Patch to fix mod_webapp under Apache 1.3 in SSL mode
Date Thu, 03 Jan 2002 01:55:55 GMT
ok have to slow down on the caffiene...

DEBIAN has used apache_mod_ssl.

Sorry for the nonsense sentence
----- Original Message -----
From: "David Graff" <phlat@mindspring.com>
To: <tomcat-dev@jakarta.apache.org>
Sent: Wednesday, January 02, 2002 20:40
Subject: Patch to fix mod_webapp under Apache 1.3 in SSL mode


> I ran into a confusing little problem with mod_webapp under Debian's
Apache
> SSL package.
>
> Apache has used the apache_mod_ssl whieh doesn't set all of the variables
> that the 'mod_ssl' package does.
>
> This causes a problem on Warp connections where the tomcat server cannot
> actually determine the correct
> security of a page requested through mod_webapp.
>
> Essentially, additional variables need to be pulled in using
ap_add_cgi_vars
> and ap_add_common_vars, then
> delay assignment of the schem variable to the request packet until a true
> determination of SSL mode (via the HTTPS variable) can be made.
>
> I didn't have a chance to look at the 2.0 version as I don't currently
have
> Apache 2.0 installed.  Enjoy.
>


----------------------------------------------------------------------------
----


> --
> To unsubscribe, e-mail:
<mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-dev-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message