tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Nielsen <gl...@voyager.apg.more.net>
Subject Re: cvs commit: jakarta-tomcat-4.0/catalina/src/share/org/apache/catalina/startup Catalina.java
Date Wed, 26 Dec 2001 17:32:43 GMT
Remy Maucherat wrote:
> 
> > glenn       01/12/26 03:00:55
> >
> >   Modified:    catalina/src/share/org/apache/catalina/startup
> Catalina.java
> >   Log:
> >   Something changed recently causes the catalina java
> >   process to hang at this point on shutdown unless there is an
> >   explicit System.exit().  Could this have something to do with
> >   the STM changes?
> 
> It does work fine for me. The change is a bad idea anyway, since the
> shutdown is asynchronous (it would be almost equivalent to not attemping to
> shutdown and kill the process).
>

The way I am using Tomcat isn't typical, the instance that fails to
terminate on shutdown is being used as a stand alone soap server which
uses https.  The only web application is the soap server.  It doesn't work
in this case.  This configuration had worked fine with Tomcat 4.0.1. This
is the first time I tried running the soap server with 4.1-dev, I wanted
to test the DbcpDataSourceFactory.

I didn't realize that the container stop was asynchronous, so you are
right, using System.exit() like this is not a good solution.  If you
look at the code you will notice that the comment says FIX ME ???. :-)
I put the System.exit() in as a temp fix.

The only cause I can come up with which would prevent the java process
from terminating is if there are still threads running which weren't
terminated by the stop. Hence the speculation that the problem has something 
to do with the STM changes.

Regards,

Glenn

----------------------------------------------------------------------
Glenn Nielsen             glenn@more.net | /* Spelin donut madder    |
MOREnet System Programming               |  * if iz ina coment.      |
Missouri Research and Education Network  |  */                       |
----------------------------------------------------------------------

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message