tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 5329] - NT Service exits startup before Tomcat is finished starting up.
Date Sat, 08 Dec 2001 22:05:43 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5329>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5329

NT Service exits startup before Tomcat is finished starting up.





------- Additional Comments From remm@apache.org  2001-12-08 14:05 -------
Many components in Tomcat are created asynchronously, but the connectors are 
not. So when the Service startup is marked are being over, the connectors have 
already been started.
The behavior of the connector may be inconsistent, in that they may return from 
the start method before they are ready to accept connections, which in some 
cases (like yours) can cause trouble. For some other connectors, like the HTTP 
connector, it is much less important than for the native webserver connectors, 
but unfortunately, all of them are currently based on the same code.
Another solution would be to have the native code in Apache be more flexible 
with the connection handling (and only connect on demand, or something like it).

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message