tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 5176] - getPathInfo() return wrong path info
Date Wed, 05 Dec 2001 01:27:01 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5176>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5176

getPathInfo() return wrong path info

moxie.j.zhang@usa.net changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|INVALID                     |



------- Additional Comments From moxie.j.zhang@usa.net  2001-12-04 17:27 -------
1. regarding Craig's cmments. I read Servlet javadoc and Servlet spec very 
carefully. There is nowhere saying that getPathInfo() could return (or 
construct) information based on a HTML <link> tag rather than the real path 
info (in request URL)sent to server. It doen't make sence even at CGI level.

2. After further investigation, the problem happens only when the getPathInfo() 
is called twice in the same method. The first time return correct path info, 
the 2nd one return wrong one.

3. After redeploy application, problem goes away, for one developer.

4. After reinstall Tomcat, problem goes away too, for another developer.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message