tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Endre StĂžlsvik <En...@Stolsvik.com>
Subject [tc4] Warp-connector reinitializing webapps
Date Wed, 28 Nov 2001 17:52:05 GMT
This won't ever be answered on the user list, so I hope for some replies
here..:

When I start apace after starting tomcat, the webapp I defined in
httpd.conf is getting initialized, even though it already got initialized
from the standalone connector..

This is part of my server.xml file:


<Server port="8005" shutdown="SHUTDOWN" debug="0">

  <!-- Define the Tomcat Stand-Alone Service -->
  <Service name="Tomcat-Standalone">

    <!-- Define a non-SSL HTTP/1.1 Connector on port 8080 -->
    <Connector className="org.apache.catalina.connector.http.HttpConnector"
               port="8080" minProcessors="5" maxProcessors="75"
               enableLookups="true" redirectPort="8443"
               acceptCount="10" debug="10" connectionTimeout="60000"/>

    <Connector className="org.apache.catalina.connector.warp.WarpConnector"
               port="8008" minProcessors="5" maxProcessors="75"
               enableLookups="true"
               acceptCount="10" debug="10"/>

    <Engine name="Standalone" defaultHost="localhost" debug="0">

      <!-- Global logger unless overridden at lower levels -->
      <Logger className="org.apache.catalina.logger.FileLogger"
              prefix="catalina_log." suffix=".txt"
              timestamp="true"/>

      <!-- Because this Realm is here, an instance will be shared globally -->
      <Realm className="org.apache.catalina.realm.MemoryRealm" />

      <!-- Define the default virtual host -->
      <Host name="localhost" debug="0" appBase="webapps" unpackWARs="true">

        <Valve className="org.apache.catalina.valves.AccessLogValve"
                 directory="logs"  prefix="localhost_access_log." suffix=".txt"
                 pattern="common"/>

        <Logger className="org.apache.catalina.logger.FileLogger"
                directory="logs"  prefix="localhost_log." suffix=".txt"
                timestamp="true"/>


This is maybe the way it's supposed to be (because it says somewhere that
each instance should be started as its own webapp), but then I wonder why
the WebappLoader logs to the two different loggers defined here. The one
that starts up automatically because of the standalone HttpConnector logs
the "startup sequnce" to the localhost_log file, while the one that starts
because of the warp connection being made by apache, logs to the
catalina_log file.

How is the warp thing working, does it in effect create an Engine for
itself, not caring of the one defined in server.xml?? Or..?

I don't get the connection thing between apache to work either, though.
Apache answers all the time that "The requested URL /[webapp] was not
found on this server. .. Apache 1.3.20", even if some connection to tomcat
apparently was made..

..All this stuff isn't _too_ well documented...


-- 
Mvh,
Endre


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message