tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 4560] New: - getParameter returning null when a value contains the equals symbol "="
Date Thu, 01 Nov 2001 11:36:39 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4560>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4560

getParameter returning null when a value contains the equals symbol "="

           Summary: getParameter returning null when a value contains the
                    equals symbol "="
           Product: Tomcat 4
           Version: 4.0.1 Final
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: jason@abstractminds.com


I'm getting a null value when I call getParameter if the value contains an 
equals.

For example the following query string:

/cfd/main?action=resetorder&forward=/mainframe.jsp%3flayout=orderentry

If I call getParameter("forward") the return is null.

If I encode the query string as follows:

/cfd/main?action=resetorder&forward=/mainframe.jsp%3flayout%3dorderentry

Then I get the correct string (eg.  "=/mainframe.jsp%3flayout%3dorderentry"

This works with previous versions of tomcat (3.2.3 and prior)

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message