tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wes Barris <...@wesbarris.com>
Subject Bug in tomcat building/installing process
Date Wed, 24 Oct 2001 05:42:06 GMT
I am trying to install either the binary or source versions of
Tomcat (version 4.0.1) on a Redhat (7.1) system.  After following the
instructions included with the binary distribution, I tried to start the
server like this:

$CATALINA_HOME/bin/startup.sh

Doing a "ps" immediately after running the above command shows a
bunch of processes like this one:

ps -auxwww | fgrep jakarta
root      2645  0.0  7.0 178312 8868 pts/2   S    13:15   0:00 /usr/java/jdk1.3.1_01/bin/i386/native_threads/java
-classpath /usr/local/jakarta-tomcat-4.0.1/bin/bootstrap.jar:/usr/java/jdk1.3.1_01/lib/tools.jar
-Dcatalina.base=/usr/local/jakarta-tomcat-4.0.1 -Dcatalina.home=/usr/local/jakarta-tomcat-4.0.1
org.apache.catalina.startup.Bootstrap start

However, all of these process die after a few seconds.  After digging
through the shell scripts in $CATALINA_HOME/bin, I have found that I
can also try to start the server in the current window like this:

root@red# $CATALINA_HOME/bin/catalina.sh run
Using CLASSPATH:     /usr/local/jakarta-tomcat-4.0.1/bin/bootstrap.jar:/usr/java/jdk1.3.1_01/lib/tools.jar
Using CATALINA_BASE: /usr/local/jakarta-tomcat-4.0.1
Using CATALINA_HOME: /usr/local/jakarta-tomcat-4.0.1
Using JAVA_HOME:     /usr/java/jdk1.3.1_01
/usr/local/jakarta-tomcat-4.0.1/bin/catalina.sh: line 234:  2653 Segmentation fault      $JAVA_HOME/bin/java
$CATALINA_OPTS -classpath $CP -Dcatalina.base=$CATALINA_BASE -Dcatalina.home=$CATALINA_HOME
org.apache.catalina.startup.Bootstrap "$@" start
root@red#

Notice the Segmentation fault.

A third method I have experimented with is debug mode:

root@red# $CATALINA_HOME/bin/catalina.sh run
> run

This mode brings the server all the way up and I am finally able
to connect to the server through a web browser like this:

http://localhost:8080/

Can anyone shed any light on what might be going wrong?

I then tried downloading and building the tomcat source distribution.
The instructions didn't say anything about it but after trial and
error I found that you also have to install the apache-devel rpm
in order to build tomcat from source.  Both the "./configure --with-apxs"
and the "make" steps completed without errors.  I then copied the newly
created mod_webapp.so file to /usr/local/apache/libexec directory.
When I test the httpd.conf file, I get this error:

root@red# /usr/local/apache/bin/apachectl configtest
Syntax error on line 236 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/mod_webapp.so into server: /usr/local/apache/libexec/mod_webapp.so:
undefined symbol: ap_ctx_get

Is this a bug in the distribution or the documentation?  What
am I missing?

I have these environment variable set:

   Set these environment variables:
   setenv JAVA_HOME     /usr/java/jdk1.3.1_01
   setenv ANT_HOME      /usr/local/jakarta-ant-1.4.1
   setenv CATALINA_HOME /usr/local/jakarta-tomcat-4.0.1

HELP!
-- 
Wes Barris                                   E-Mail: wes@wesbarris.com
WesBarris dot Com                           USA Fax: 413-375-0210
                                       Phone in AUS: 07-3876-2301
www.wesbarris.com                    Phone from USA: 001-617-3876-2301
----------------------------------------------------------------------
Today's fortune: Some people never learn anything because they
understand everything too soon. -- Alexander Pope

Mime
View raw message