tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 4354] New: - fatal relocation error for __lshrdi3
Date Mon, 22 Oct 2001 22:22:06 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4354>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4354

fatal relocation error for __lshrdi3

           Summary: fatal relocation error for __lshrdi3
           Product: Tomcat 4
           Version: 4.0.1 Final
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: Webapps
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: jim@mail.ucf.edu


Hello,

I am trying to compile the tomcat webapp module 1.0 on a Solaris 8 system and I
am am getting these messages when running the 'apachectl configtest' command.  I
tried using the binary version of the module earlier and got similar errors:

cougar:/web/apache#./bin/apachectl configtest
Syntax error on line 206 of /web/apache_1.3.22/conf/httpd.conf:
Cannot load /web/apache_1.3.22/libexec/mod_webapp.so into server: ld.so.1:
/web/apache_1.3.22/bin/httpd: fatal: relocation error: file
/web/apache_1.3.22/libexec/mod_webapp.so: symbol __lshrdi3: referenced
symbol not found

I did a clean configure of the webapp module and it looked like it compiled
okay. I am using Apache 1.3.22.

Mime
View raw message