tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Frankson" <dfrank...@qwest.net>
Subject memory leak?
Date Fri, 12 Oct 2001 15:21:59 GMT
    I've been using Tomcat 3.2.3 in a production environment for a couple months without a
problem.  Last week I added a new feature and now the tomcat process will consume memory until
it reaches the -Xmx512 size I have set.  

I ran the same webapp under Tomcat 4.0 and I see the same behavior.   However, I ran the same
webapp under resin 2.0.2 and there is no evidence of a memory leak. 

I downloaded JProbe to take a look at the heap, and the most interesting thing I found was
that there was a 33Mb byte[] referenced by HttpResponseAdapter.  I didn't see any objects
from my application code that weren't supposed to be there.

Has anyone encountered something like this?  What in my application can cause Tomcat to hold
onto memory and never release it?  

Dave Frankson

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message