tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cmanola...@yahoo.com>
Subject Re: [PATCH] to get Client Certificates in TC3.3
Date Fri, 21 Sep 2001 16:44:52 GMT
On Fri, 21 Sep 2001, jean-frederic clere wrote:

> > Regarding CertCompat: I'm not sure we need it, the functions could be
> > added to jdk11Compat. It's not a big deal, I can change this after you
> > commit ( unless you have reasons or a preference to create a compat class
> > for cert-related code - which is ok ).
>
> I prefer to have a CertCompat because we could have Java2 and no JSSE.
> Is JSSE and JDK1.1 possible?

Are you using JSSE in CertCompat ? If so - you're absolutely right (
well, maybe we should call it JsseCompat ? ). Even better - we can extend
it to support other SSL-toolkits ( I know there is a OpenSSL
wrapper around ).


Costin
( sorry, I thought you're only using java.security.cert, which is JDK1.2+
but doesn't require JSSE )


Mime
View raw message