tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars R. Ribe" <r...@hi.au.dk>
Subject cant't compile webapp_module
Date Fri, 28 Sep 2001 12:27:55 GMT
Hi folks.
Sorry to bother you, but I have a problem compiling the webapp_module,
so I hoped you have som ideas:
I run configure --with-apxs, which runs well (as far as I can see).
But when I run make, I get the following error:

<clip>
make[1]: Entering directory `/usr/tomcat/webapp-module-1.0-tc40'

make[1]: Entering directory "lib"
make[1]: Invoking "make  build"
make[2]: Entering directory `/usr/tomcat/webapp-module-1.0-tc40/lib'
make[2]: Generating "pr_warp_defs.h"
/usr/bin/gcc -g -O2  -g -O2 -DLINUX=2 -D_REENTRANT
-I/usr/tomcat/webapp-module-1.0-tc40/apr/include
-I/usr/tomcat/webapp-module-1.0-tc40/include -c "wa_main.c" -o
"wa_main.o"
In file included from
/usr/tomcat/webapp-module-1.0-tc40/apr/include/apr_general.h:61,
                 from
/usr/tomcat/webapp-module-1.0-tc40/include/wa.h:77,
                 from wa_main.c:59:
/usr/tomcat/webapp-module-1.0-tc40/apr/include/apr.h:292:27:
sys/syslimits.h: No such file or directory
make[2]: *** [wa_main.o] Error 1
make[2]: Leaving directory `/usr/tomcat/webapp-module-1.0-tc40/lib'
make[1]: Exiting directory "lib"
make[1]: *** [template] Error 2
make[1]: Leaving directory `/usr/tomcat/webapp-module-1.0-tc40'
make: *** [lib-build] Error 2
<clip>

If you know the answer, please mail me back

Thank you

Lars Ribe


Mime
View raw message