tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: Build system for mod_webapp and Apache 2.0
Date Wed, 05 Sep 2001 16:57:08 GMT
Ryan Bloom wrote:
> 
> On Wednesday 05 September 2001 04:13, jean-frederic clere wrote:
> 
> If you don't remove the --disable-shared, then libtool 1.4 can't compile
> mod_webapp as a dynamic library.

I just want a DSO file...

- On my Linux if I remove the --disable-shared to the APR, libtool complains
when building mod_webapp.so:
  something like that "we use dynamic library we have to install them"... (That
is libtool 1.3.5)

Are you suggesting to use dynamic libapr and libwebapp?

>  It really sucks, but complain to the
> libtool developers.  That flg must go, or we break anybody who tries to use
> the latest version of libtool.  :-(

I will try tomorrow with the lastest version of libtool.

> 
> Ryan
> 
> > Hi,
> >
> > I have committed it. Note that the --disable-shared MUST NOT be removed
> > otherwise libtool uses the dynamic libraries and we want it to use the
> > static ones.
> >
> > Cheers
> >
> > Jean-frederic
> 
> ______________________________________________________________
> Ryan Bloom                              rbb@apache.org
> Covalent Technologies                   rbb@covalent.net
> --------------------------------------------------------------

Mime
View raw message