tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 3653] New: - Using %25 in URLs is not handled correctly
Date Mon, 17 Sep 2001 15:28:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3653>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3653

           Summary: Using %25 in URLs is not handled correctly
           Product: Tomcat 3
           Version: 3.2.3 Final
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Servlet
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: gb@opengroup.org


Hi,When I use a URL with %25 in it on tomcat3.2.3 I get a Tomcat 404 back, however if I use
the same URL on tomcat3.2.2 it works o.k.This seems to be worse when the %25 is in the requested
filename.I've found other URL escapes o.k. for example %24 and %26.  It appears that either
the server (in this Apache) is unescaping the URL to just put it as % and then when it hits
Tomcat it then barfs because it doesn't understand the plain %. I have compared the configuration
on both tomcat3.2.3 and 3.2.2 and they are the same so I can only believe it is a problem
with Tomcat.I know the message is coming from Tomcat because I get a message in the tomcat.log.Please
help,Gary

Mime
View raw message