tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 3641] New: - Bad value in query string parameter while forwarding request
Date Sun, 16 Sep 2001 10:39:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3641>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3641

           Summary: Bad value in query string parameter while forwarding
                    request
           Product: Tomcat 3
           Version: 3.3 Beta 2
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Servlet
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: d.gaffuri@reply.it


Hi

I have the following problem with query string parameters in the target URI 
while forwarding a request from one JSP to another.

Have a first JSP (forward.jsp) looking like

<jsp:forward page="target.jsp?PARAM=SECOND"/>

and a second one (target.jsp) which shows the value of the PARAM parameter

<html>
    <body><%= request.getParameter("PARAM") %></body>
</html>

When you invoke forward.jsp without a query string you correctly get SECOND as 
the parameter value, but with

forward.jsp?PARAM=FIRST

the shown value is FIRST. This happens also using

<jsp:forward page="target.jsp">
    <jsp:param name="PARAM" value="SECOND"/>
</jsp:forward>

as forward.jsp.

Both Tomcat 3.2.2 and Tomcat 4.0 rc1 show SECOND as the value parameter in all 
cases, as required by servlet 2.2 specs.

Mime
View raw message