tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 3612] New: - getServletPath() method returns wrong value
Date Fri, 14 Sep 2001 14:03:23 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3612>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3612

           Summary: getServletPath() method returns wrong value
           Product: Tomcat 4
           Version: 4.0 Release Candidate 1
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: account.consult-smi@airbus.fr


Sometimes, a call to getServletPath() [in HttpServletRequest] returns the 
path "/servlet" instead of lets say "/servlet/TestServlet".

It seems as if this only occurs if the servlet is NOT loaded yet. Then 
only /servlet is returned. A second call to the servlet returns the correct 
path information.

(After a webapp-reload from within the manager application, the call still 
returns the correct value. If the webapp is stopped and restarted, the first 
call to a servlet returns the wrong value again.)

JSP Pages always return correct path information.

(I also have filters in front of my servlets)

Mime
View raw message