tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [DO NOT REPLY: Bug 3589] New: Cannot process Taglib TLD when deployed through EmbeddedManager MBean
Date Thu, 13 Sep 2001 16:39:18 GMT
PLEASE DO NOT REPLY TO THIS MESSAGE. TO FURTHER COMMENT
ON THE STATUS OF THIS BUG PLEASE FOLLOW THE LINK BELOW
AND USE THE ON-LINE APPLICATION. REPLYING TO THIS MESSAGE
DOES NOT UPDATE THE DATABASE, AND SO YOUR COMMENT WILL
BE LOST SOMEWHERE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3589

*** shadow/3589	Thu Sep 13 09:39:18 2001
--- shadow/3589.tmp.8848	Thu Sep 13 09:39:18 2001
***************
*** 0 ****
--- 1,39 ----
+ +============================================================================+
+ | Cannot process Taglib TLD when deployed through EmbeddedManager MBean      |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 3589                        Product: Tomcat 4                |
+ |       Status: NEW                         Version: 4.0 Release Candidate 1 |
+ |   Resolution:                            Platform: PC                      |
+ |     Severity: Blocker                  OS/Version: Windows NT/2K           |
+ |     Priority: Other                     Component: Catalina                |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: tomcat-dev@jakarta.apache.org                                |
+ |  Reported By: rickard@xpedio.com                                           |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ When deploying a WAR file ny putting it in /webapps and starting Catalina "the 
+ usual way", it works.
+ 
+ When deploying the same WAR file through the JMX EmbeddedManager MBean (from 
+ within JBoss) it chokes while parsing the TLD somehow. The Catalina logs say 
+ this:
+ 2001-09-13 17:12:35 ContextConfig[/webwork]: Scanning web.xml tag libraries
+ 2001-09-13 17:12:35 ContextConfig[/webwork]:   URI='webwork', 
+ ResourcePath='/WEB-INF/lib/webwork.jar'
+ 2001-09-13 17:12:35 ContextConfig[/webwork]:     
+ tldConfigJar(/WEB-INF/lib/webwork.jar): java.lang.IllegalStateException: zip 
+ file closed
+ 2001-09-13 17:12:35 ContextConfig[/webwork]:     
+ tldConfigTld(/WEB-INF/lib/webwork.jar): org.xml.sax.SAXParseException: The 
+ markup in the document preceding the root element must be well-formed.
+ 2001-09-13 17:12:35 ContextConfig[/webwork]: Scanning library JAR files
+ ...
+ 
+ What could be wrong? Is it in Catalina or the calling code? Any ideas?
+ 
+ This is the last stumbling block before I have Catalina integrated with JBoss...
+ 
+ /Rickard

Mime
View raw message