tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob S." <rsli...@sfu.ca>
Subject Re: Problem (or is it?) building new TC4 beta
Date Fri, 10 Aug 2001 11:10:18 GMT
Heyya Christopher, I'll send you my Win98 build file when I get home if you
can wait that long =)

- r

On Fri, 10 Aug 2001 11:37:15 -0600 tomcat-dev@jakarta.apache.org wrote:
> Hopefully this isn't one of those brain-dead things like last night :-)
> 
> I'm seeing the following during the build process (NT4 w/ Sun 1.3.1):
> 
> ...
> 
> build-static:
>   [copy] Copying 9 files to
> C:\jakarta\jakarta-tomcat-4.0\catalina\build\bin
>   [copy] Copying 5 files to
> C:\jakarta\jakarta-tomcat-4.0\catalina\build\conf
>   [copy] Could not find file
>
C:\jakarta\jakarta-tomcat-4.0\jakartajakarta-servletapi-4dist\lib\servlet.ja

> r
> to copy
>   [copy] Could not find file
> C:\jakarta\jakarta-tomcat-4.0\javajndi1.2.1\lib\jndi.jar to copy
>   [copy] Could not find file
> C:\jakarta\jakarta-tomcat-4.0\javajaxp-1.1\crimson.jar to copy
> 
> BUILD FAILED
> 
> C:\jakarta\jakarta-tomcat-4.0\catalina\build.xml:100
> C:\jakarta\jakarta-tomcat-4.0\jakartajakarta-regexpbin not found.
> 
> ---------------------
> 
> It looks like maybe Ant isn't escaping the backslashes in
> build.properties, and is in fact treating them AS escape characters. The
> relevant parts of my file look like this:
> 
> base.path=c:\java
> 
> jaxp.home=${base.path}\jaxp-1.1
> jaxp.parser.jar=crimson.jar
> 
> ... (and so on, since all Sun stuff on this box is under c:\java\*)
> 
> Now I have all of the jakarta stuff in c:\jakarta\*, so the last three
> entries look like this:
> 
> regexp.home=c:\jakarta\jakarta-regexp\bin
> servletapi.home=c:\jakarta\jakarta-servletapi-4\dist
> using.jdk.1.3=true
> 
> Do I not have my build.properties set up correctly for Windoze, or is
> this a known problem? If so, what's the workaround?
> 
> Thanks ...
> 
> - Christopher




Mime
View raw message