tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Ball <ba...@webslingerZ.com>
Subject bugs in mod_webapp
Date Fri, 29 Jun 2001 03:48:51 GMT
new thread name since i've got me some real bugs to note, not just my
stupid compilation and configuration problems.

1. when tomcat is restarted while apache is running, mod_webapp returns
errors for all further tomcat requests. apache's error_log reports:

[Thu Jun 28 23:45:55 2001] 17320 (pr_warp.c:348) Cannot read from socket
[Thu Jun 28 23:45:55 2001] 17320 (pr_warp.c:228) Disconnecting
"myConnection"
[Thu Jun 28 23:45:55 2001] 17320 (pr_warp.c:373) NO RID (-1)

[Thu Jun 28 23:45:55 2001] 17320 (pr_warp.c:522) WARP provider started
[Thu Jun 28 23:45:55 2001] 17320 (wa_main.c:108) WebApp Library started
[Thu Jun 28 23:45:55 2001] 17293 (pr_warp.c:348) Cannot read from socket
[Thu Jun 28 23:45:55 2001] 17293 (pr_warp.c:228) Disconnecting
"myConnection"
[Thu Jun 28 23:45:55 2001] 17293 (pr_warp.c:373) NO RID (-1)

[Thu Jun 28 23:45:55 2001] 17293 (pr_warp.c:522) WARP provider started
[Thu Jun 28 23:45:55 2001] 17293 (wa_main.c:108) WebApp Library started
[Thu Jun 28 23:45:55 2001] 17294 (pr_warp.c:348) Cannot read from socket
[Thu Jun 28 23:45:55 2001] 17294 (pr_warp.c:228) Disconnecting
"myConnection"
[Thu Jun 28 23:45:55 2001] 17294 (pr_warp.c:373) NO RID (-1)

[Thu Jun 28 23:45:55 2001] 17294 (pr_warp.c:522) WARP provider started
[Thu Jun 28 23:45:55 2001] 17294 (wa_main.c:108) WebApp Library started
[Thu Jun 28 23:45:55 2001] 17292 (pr_warp.c:348) Cannot read from socket
[Thu Jun 28 23:45:55 2001] 17292 (pr_warp.c:228) Disconnecting
"myConnection"
[Thu Jun 28 23:45:55 2001] 17292 (pr_warp.c:373) NO RID (-1)

[Thu Jun 28 23:45:55 2001] 17292 (pr_warp.c:522) WARP provider started
[Thu Jun 28 23:45:55 2001] 17292 (wa_main.c:108) WebApp Library started
[Thu Jun 28 23:45:55 2001] 17291 (pr_warp.c:348) Cannot read from socket
[Thu Jun 28 23:45:55 2001] 17291 (pr_warp.c:228) Disconnecting
"myConnection"
[Thu Jun 28 23:45:55 2001] 17291 (pr_warp.c:373) NO RID (-1)

[Thu Jun 28 23:45:55 2001] 17291 (pr_warp.c:522) WARP provider started
[Thu Jun 28 23:45:55 2001] 17291 (wa_main.c:108) WebApp Library started
[Thu Jun 28 23:46:35 2001] 17290 (pr_warp.c:269) Cannot write to socket
[Thu Jun 28 23:46:35 2001] 17290 (pr_warp.c:228) Disconnecting
"myConnection"
[Thu Jun 28 23:46:35 2001] 17290 (pr_warp.c:237) Cannot shutdown
"myConnection"
[Thu Jun 28 23:46:50 2001] [error] I/O Error
[Thu Jun 28 23:47:26 2001] [error] We are disconnected
[Thu Jun 28 23:47:26 2001] [error] Application not deployed correctly
[Thu Jun 28 23:47:26 2001] 17294 (pr_warp.c:255) Socket not initialized
[Thu Jun 28 23:47:26 2001] 17294 (pr_warp.c:228) Disconnecting
"myConnection"
[Thu Jun 28 23:47:26 2001] [error] I/O Error

and then keeps repeating the 'We are disconnected' bit for each request.

2. after apache has started, the first request always times out.
catalina.out reports:

java.lang.IllegalArgumentException: addChild:  Child name
'foobar.webslingerz.com.80' is not unique
        at
org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
        at
org.apache.catalina.core.StandardEngine.addChild(StandardEngine.java:236)
        at
org.apache.catalina.connector.warp.WarpEngine.addChild(WarpEngine.java:181)
        at
org.apache.catalina.connector.warp.WarpEngine.setupChild(WarpEngine.java:166)
        at
org.apache.catalina.connector.warp.WarpConnectionHandler.process(WarpConnectionHandler.java:105)
        at
org.apache.catalina.connector.warp.WarpHandler.run(WarpHandler.java:156)
        at java.lang.Thread.run(Thread.java:484)
[org.apache.catalina.connector.warp.WarpRequestHandler]
    End of request
[org.apache.catalina.connector.warp.WarpRequestHandler]
    Thread exited

but after that, it's fine.

- donald


Mime
View raw message