tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Ball <ba...@webslingerZ.com>
Subject Re: problem with mod_webapp
Date Fri, 29 Jun 2001 02:46:10 GMT
On Fri, 29 Jun 2001, Pier P. Fumagalli wrote:

> Oh, I believe you specified your WebAppDeploy _before_ your ServerName
> directive... If you switch them it should be fine...

aha! voila! WebAppInfo now works great, but WebAppDeploy still fails, i
now get timeouts when i try to hit urls assigned to my webapp. apache's
error_log says:

[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:459) Host
chngw.webslingerZ.com:80 has ID 0
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=0 TYP=2
LEN=24
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:478) Application intranet
under /intranet/ has ID 6
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:522) WARP provider started
[Thu Jun 28 22:41:03 2001] 16006 (wa_main.c:108) WebApp Library started
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=0 TYP=4
LEN=4
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=16
LEN=5
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=17
LEN=36
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=18
LEN=2
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=19
LEN=10
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=100
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=49
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=55
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=28
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=25
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=24
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=34
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=29
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=18
[Thu Jun 28 22:41:03 2001] 16006 (pr_warp.c:324) Sent packet CID=1 TYP=20
LEN=60
[Thu Jun 28 22:41:04 2001] 16037 (pr_info.c:72) INFO provider started
[Thu Jun 28 22:41:04 2001] 16037 (pr_warp.c:439) Configuring application
"intranet" for http://chngw.webslingerZ.com:80/intranet/
[Thu Jun 28 22:41:04 2001] 16037 (pr_warp.c:324) Sent packet CID=0 TYP=0
LEN=25
[Thu Jun 28 22:41:59 2001] 16006 (pr_warp.c:744) Status1 "HTTP/1.1"
[Thu Jun 28 22:41:59 2001] 16006 (pr_warp.c:746) Status2 "OK"
[Thu Jun 28 22:41:59 2001] 16006 (pr_warp.c:753) Header "Content-Type":
"text/html"
[Thu Jun 28 22:41:59 2001] 16006 (pr_warp.c:412) SHORT len=2048 siz=4096

and catalina.out says:

java.lang.IllegalArgumentException: addChild:  Child name
'chngw.webslingerz.com.80' is not unique
        at
org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
        at
org.apache.catalina.core.StandardEngine.addChild(StandardEngine.java:236)
        at
org.apache.catalina.connector.warp.WarpEngine.addChild(WarpEngine.java:181)
        at
org.apache.catalina.connector.warp.WarpEngine.setupChild(WarpEngine.java:166)
        at
org.apache.catalina.connector.warp.WarpConnectionHandler.process(WarpConnectionHandler.java:105)
        at
org.apache.catalina.connector.warp.WarpHandler.run(WarpHandler.java:156)
        at java.lang.Thread.run(Thread.java:484)

but oddly enough, i just tried again and it's working (!) with one caveat
- the connection to my web browser is never closed, or else is closed a
long while after all of the data has been sent (the icon keeps spinning
after the page is downloaded, in other words).

are these "expected" bugs or should i try to isolate them and report on
'em?

in general, are tomcat developers comfortable with mod_webapp's stability?
or is it still very much a work in progress?

- donald


Mime
View raw message