tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pier P. Fumagalli" <p...@betaversion.org>
Subject Re: [J-T-C] 1 second for crash (was: httpd crash)
Date Wed, 20 Jun 2001 17:10:47 GMT
francesco.casalena@virgilio.it at francesco.casalena@virgilio.it wrote:

> Sorry Pier, 
> my previous httpd log was wrong :)
> 
> These are ok:
> -------
> [root@localhost jakarta-tomcat-4.0-b5]# /usr/local/apache/bin/apachectl start
> [Wed Jun 20 16:57:34 2001] 1699 (pr_info.c:66) INFO provider initialized
> [Wed Jun 20 16:57:34 2001] 1699 (pr_warp.c:492) WARP provider initialized
> [Wed Jun 20 16:57:34 2001] 1699 (wa_main.c:98) WebApp Library initialized
> [Wed Jun 20 16:57:35 2001] 1699 (wa_config.c:163) Created connection
> "warpConnection"
> (Prov: "warp" Param: "localhost:8008")
> [Wed Jun 20 16:57:35 2001] 1699 (wa_config.c:122) Created virtual host
> "localweb:80"
> [Wed Jun 20 16:57:35 2001] 1699 (wa_config.c:97) Created application
> "examples"
> in path "/examples/"
> [Wed Jun 20 16:57:35 2001] 1699 (wa_main.c:184) Application examples deployed
> for http://localweb:80/examples/ (Conn: warpConnection)
> [Wed Jun 20 16:57:35 2001] 1699 (pr_info.c:83) Provider is configuring
> "_INFO_"
> with parameter ""
> [Wed Jun 20 16:57:35 2001] 1699 (wa_config.c:163) Created connection "_INFO_"
> (Prov: "info" Param: "")
> [Wed Jun 20 16:57:35 2001] 1699 (wa_config.c:97) Created application "_INFO_"
> in path
> "/info/"
> [Wed Jun 20 16:57:35 2001] 1699 (pr_info.c:91) Provider is deploying _INFO_
> for
> http://localweb:80/info/ (Conn: _INFO_)
> /usr/local/apache/bin/apachectl start: httpd started
> ------
> 
> Apache's error_log:
> 
> ------
> [root@localhost jakarta-tomcat-4.0-b5]# less /usr/local/apache/logs/error_log
> [Wed Jun 20 16:57:35 2001] [info] mod_unique_id: using ip addr 127.0.0.1
> [Wed Jun 20 16:57:36 2001] 1700 (pr_info.c:77) INFO provider destroyed
> [Wed Jun 20 16:57:36 2001] 1700 (pr_warp.c:531) Destroying connection
> "warpConnection"[Wed Jun 20 16:57:36 2001] 1700 (pr_warp.c:228) Disconnecting
> "warpConnection"
> [Wed Jun 20 16:57:36 2001] 1700 (pr_warp.c:536) WARP provider destroyed
> [Wed Jun 20 16:57:36 2001] 1700 (wa_main.c:127) WebApp Library destroyed
> -------
> 
> 1 sec for Apache crash!!!
> 
> What do you think about crash reason?

No, because frankly there doesn't seem to be anything triggering that
shutdown... Usually apache reports what signal it got when it's shutting
down, but there's nothing in the output...
The only thing I see that is not in my config is mod_unique_id, can you send
me a detailed log with LogLevel set to DEBUG in your httpd.conf (do it
privately -and in Italian, it works better :) - don't want to spam 5000
people with it)...

And also, what version of Apache you're using...

I don't get it...

    Pier


Mime
View raw message