tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amy Roh <...@betaversion.org>
Subject Re: Tomcat4.0 does not compile with jdk1.2.2
Date Wed, 06 Jun 2001 15:42:42 GMT
Please remove those files from your source tree if you're using jdk1.2.2.  I'll 
fix this after JavaOne this week.  

Amy

Quoting jean-frederic clere <jfrederic.clere@fujitsu-siemens.com>:

> Hi,
> 
> I have noted that ProcessHelper.java and  CGIServlet.java use jdk1.3.1
> but this
> code cannot compile with jdk1.2.2...
> +++
>     [javac]
> /home/jakarta/jakarta-tomcat-
4.0/catalina/src/share/org/apache/catalina/servlets/CGIServlet.java:1567:
> Wrong number of arguments in method.         
>     [javac]         proc = rt.exec(cmdAndArgs.toString(),
> hashToStringArray(env),
> wd);                                                                    
>      
>     [javac]                       ^                                     
>        
>     [javac]
> /home/jakarta/jakarta-tomcat-
4.0/catalina/src/share/org/apache/catalina/util/ProcessHelper.java:381:
> Wrong number of arguments in method.           
>     [javac]     proc = rt.exec(cmdAndArgs.toString(),
> hashToStringArray(env),
> wd);                                                                    
>          
>     [javac]                   ^                                         
>        
>     [javac] Note: 13 files use or override a deprecated API.  Recompile
> with
> "-deprecation" for
> details.                                                        
>     [javac] 2 errors, 1 warning                                         
>        
> +++
> 
> The 3d argument have been added in jdk1.3.1 - What should I do? -
> 
> Cheers
> 
> Jean-frederic
> 

Mime
View raw message