tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wildeboer, Tonnis" <twild...@Covad.COM>
Subject RE: Class Loader Problem?
Date Wed, 09 May 2001 00:46:40 GMT
Well, I considered all those things and finally, I did the only thing you
can do when things get this weird:
I did a completely clean checkout and rebuild of everything and of course...
problem solved. Guess I'll never know what was really happening, but the
experience (and solution) is a lesson in itself...

Thanks for your reply.


-----Original Message-----
From: Bip Thelin []
Sent: Tuesday, May 08, 2001 4:48 PM
Subject: Re: Class Loader Problem?

"Wildeboer, Tonnis" wrote:
> [...]
> I have gone so far as completely removing VCALookup.class from my classes
> directory and I still get the same Exception.
> I also tried instantiating the class from a different file (first line of
> doGet()) and still get the same Exception.
> I copied a known good class (my servlet class), renamed it to
> VCALookup.class, same Exception.

Ok, this is what the Javadocs say about java.lang.ClassFormatError.

Thrown when the Java Virtual Machine attempts to read a class file and
determines that the file is malformed or otherwise cannot be interpreted as
a class file.

I interpret this as that the classloader are _finding_ the class but has
loading it.
What is this file/class? Something you copied from somewhere? Could it be
you are missing an inline class for VCALookup? i.e.
I would think that there's something wrong with the VCALookup class, if it
find the file you wou'd have gotten a ClassNotFoundException. Is VCALookup
to any other classed that you've missed to bring to your Tomcat env?

> 2001-05-01 04:19:15 - Ctx(  ): Exception in: R(  + /csp + /+cfi/login) -
> java.lang.ClassFormatError: VCALookup (Truncated
>  class file)
>         at java.lang.ClassLoader.defineClass0(Native Method)
>         at java.lang.ClassLoader.defineClass0(Compiled Code)
>         at java.lang.ClassLoader.defineClass(Compiled Code)
>         at Code)
>         at Code)
>         at$1(Compiled Code)
>         at$ Code)
>         at Method)
>         at Code)
>         at Code)
>         at java.lang.ClassLoader.loadClass(Compiled Code)
>         at sun.misc.Launcher$AppClassLoader.loadClass(Compiled Code)
>         at java.lang.ClassLoader.loadClass(Compiled Code)
>         at org.apache.tomcat.loader.AdaptiveClassLoader.loadClass(Compiled
> Code)
>         at java.lang.ClassLoader.loadClass(Compiled Code)
>         at java.lang.ClassLoader.loadClassInternal(Compiled Code)
>         at MediatorAgent.printTemplateResponse(Compiled Code)
>         at MediatorAgent.printResponse(
>         at MainVCAServlet.doGeneral(Compiled Code)
>         at MainVCAServlet.doGet(
>         at javax.servlet.http.HttpServlet.service(
>         at javax.servlet.http.HttpServlet.service(
>         at
> org.apache.tomcat.core.ServletWrapper.doService(
>         at org.apache.tomcat.core.Handler.service(
>         at
> org.apache.tomcat.core.ServletWrapper.service(
>         at
> 7)
>         at
> org.apache.tomcat.core.ContextManager.service(
>         at
>         at org.apache.tomcat.service.TcpWorkerThread.runIt(Compiled Code)
>         at org.apache.tomcat.util.ThreadPool$
> Code)
>         at Code)

Sorry I can't help you more.


View raw message