tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 132] New - No workers found when trying to access jsp or servlet through mod_jk and apache BugRat Report#148
Date Mon, 07 May 2001 14:32:34 GMT
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=132

*** shadow/132	Mon May  7 07:32:33 2001
--- shadow/132.tmp.16461	Mon May  7 07:32:33 2001
***************
*** 0 ****
--- 1,33 ----
+ +============================================================================+
+ | No workers found when trying to access jsp or servlet through mod_jk and a |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 132                         Product: Tomcat 3                |
+ |       Status: UNCONFIRMED                 Version: 3.2.1 Final             |
+ |   Resolution:                            Platform: All                     |
+ |     Severity: Normal                   OS/Version: All                     |
+ |     Priority: High                      Component: Connectors              |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: hgomez@slib.fr                                               |
+ |  Reported By: mikael.andersson@front.se                                    |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ This seems to be a serious problem, atleast on my platform
+ as no jsp/servlet pages can be served through apache while 
+ expiriencing this condition.
+ 
+ When accessing a jsp page through apache i get the following error in jk.log
+ [jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
+ [jk_worker.c (127)]: wc_get_worker_for_name, done did not found a worker
+ 
+ I can access the same .jsp through tomcat when accessing it 
+ directly. 
+ 
+ When apache is started  "jk_post_config NULL" is written st
+ stdout. i checked the source and i assume that WAS_BORN_BY_APACHE
+ is not accessible to mod_jk. This leads to mod_jk being started without any workers initialized.
+ 
+ ------- Additional Comments From hgomez@slib.fr  2001-05-07 07:32 -------
+ Fixed since 3.2.1 and in 3.3

Mime
View raw message