tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrey Kartashov <andrey.kartas...@sonatainc.com>
Subject Re: ERROR using multipart/form-data POST request
Date Fri, 27 Apr 2001 16:55:01 GMT
On Fri, Apr 27, 2001 at 03:57:43AM +0200, Incze Lajos wrote:
> > This error hapens when I try to upload file using form with
> > enctype="multipart/form-data" and method="post".
> > 
> > The environment: Linux(2.4.3), Apache(1.3.19),
> > mod_jk and Tomcat (3.2.1), using ajp13 protocol.
> > 
> > 
> > I can't seem to find anything like that in apache bug tracking system.
> > Did anyone have any experience using multipart/form-data with similar
> > server configuration?
> > 
> I think you should change to an 3.2.2 beta, as modjk had some difficulties
> in the 3.2.1 tomcat release.                                       incze

I just tested ajp12 protocol and it doesn't have this bug.
I'm going to test 3.2.2 stuff as well some time later:) Just in case if someone
else wants to try - this bug is triggered when uploading binary data
(like image file). Uploading of the text file works (even a big one).
I'd guess that code uses string functions somewhere where binary read/write 
would be more appropriate.


-- 
oo Andrey
oo
oOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOo
"All mail clients suck. This one just sucks less."
           -- http://www.mutt.org/  Jeremy Blosser
oOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOoOo


Mime
View raw message