tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Remy Maucherat" <r...@apache.org>
Subject Re: [CATALINA b2] weird issue
Date Mon, 02 Apr 2001 08:41:47 GMT
> Craig,
>
> It seems that there is a bug in 4.0b2 where you must have at least one
> <context> defined in the server.xml. Is that right? It seems to me that
the
> system should just pick up whatever .war files are in the webapps
directory
> without having to define a <context> for each one or at all. This works
with
> 3.2.2b2.
>
> You can replicate this by:
>
>     grab this file:
>
<http://jakarta.apache.org/builds/jakarta-velocity/demo/forumdemo-tomcat-3.2
> .2b2.tar.gz>
>
> Take the forumdemo.war file out of the webapps directory.
>
> Delete all of the <context>'s in the server.xml file.
>
> start up tomcat 4.0b2.
>
> try to access:
>
> http://jonlap:8080/forumdemo/servlet/forum
>
> right now, i get:
>
> "HTTP Status 503 - This application is not currently available
> The requested service (This application is not currently available) is not
> currently available. "
>
> The .war file works fine with a stock 4.0b2 distribution, but if I try to
> remove the <Context path="/examples" docBase="examples" debug="0"
> reloadable="true"> from the server.xml file, then I start to run into a
> whole heap of problems.

I can't reproduce that one.
I removed all context defs from my server.xml, and everything still works
fine. You can check the logs to try to figure out what's going on.

Remy


Mime
View raw message