tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: Still have XML loading problems
Date Fri, 23 Mar 2001 19:05:02 GMT
Kevin Jones wrote:

> Craig,
>
> I'm playing with the 22nd March drop of Catalina, and I've come across a
> scenario where the new classloading architecture doesn't quite work.
>
> I'm using Xerces and Xalan (although Xalan is irrelevant to this). If I
> access a servlet that uses XML and I don't put Xerces in my
> web-app/myapp/lib my code fails (exactly what I'd expect). If I put
> Xerces.jar into web-app/myapp/lib it works, again what I'd expect.
>
> However, if I put my XML code into an application listener then Jasper fails
> to load - I get a Security Exception, sealing violation, while it's load the
> 'jsp' servlet. It seems that what's happening is that my listener loads,
> loads Xerces and executes OK. The jsp Servlet then tries to load
> crimson/JAXP and *bang* sealing violation.
>

I will bet you're using a JDK 1.3 platform, right?  It turns out that all the
changes we made are very effective for JDK 1.2, but the 1.3 version of
URLClassLoader still doesn't like it.  :-(

>
> Sorry about this - the XML stuff had been going so well until then!
>

I think the only workaround for this is to ship our own copy of the JAXP JAR
files, with the "sealed" attribute removed.  I'm also going to be talking with
the JAXP folks about removing that in their next release.


>
> Kevin Jones
> DevelopMentor
> www.develop.com

Craig



Mime
View raw message