tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 110] New - JCE 1.2.1 support is not handled correctly BugRat Report#116
Date Sat, 10 Mar 2001 01:04:09 GMT
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=110

*** shadow/110	Fri Mar  9 17:04:09 2001
--- shadow/110.tmp.11036	Fri Mar  9 17:04:09 2001
***************
*** 0 ****
--- 1,17 ----
+ +============================================================================+
+ | JCE 1.2.1 support is not handled correctly BugRat Report#116               |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 110                         Product: Tomcat 3                |
+ |       Status: UNCONFIRMED                 Version: 3.1.1 Final             |
+ |   Resolution:                            Platform: All                     |
+ |     Severity: Normal                   OS/Version: All                     |
+ |     Priority: High                      Component: Unknown                 |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: Larry.Isaacs@sas.com                                         |
+ |  Reported By: anonymous-bug@cortexity.com                                  |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ I am running the latest and greatest Java/Tomcat/JCE on a Solaris 2.7 intel box. I have
loaded all the OS patches per the sun and java sites. I have a couple classes which implement
the Blowfish encryption algorithm using the JCE. These work standalone when compiled using
javac and executed via java command line. Each works if the JCE is statically configured via
the java.security file or dynamically via the addProvider() call. When I call these classes
from a jsp using Tomcat I get an error "Cannot set up certs for trusted CAs" I have tried
using various JVMs by setting the jvm.cfg file (Hotspot, et. al) Standalone things work fine,
jsp compilation/execution from Tomcat errors. Any help is appreciated.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, email: tomcat-dev-help@jakarta.apache.org


Mime
View raw message