tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sam Ruby" <ru...@us.ibm.com>
Subject Re: [PATCH] CatalinaBlock.java
Date Mon, 12 Feb 2001 18:39:07 GMT
Aaron Mulder wrote:
>
> It's always going to be the case that the Avalon and Tomcat releases
> don't sync up perfectly.  How would you feel about making any Tomcat
> changes necessary to support the Avalon patch, but maintaining the
> Avalon block itself outside of the main Tomcat 4.0 module?  That way the
> Avalon support could be updated independently for new releases of Avalon
> *or* Tomcat.

Avalon is currently in Alpha.  This means that their APIs are subject to
change.

Once they ever release (or rather, if they ever release <grin>), then I
have been told that their APIs will be stable, and they will try to
maintain version to version incompatibility.

My preference is that mainline subprojects (no, I don't have a definition
for that term, but Tomcat clearly qualifies) do not support Avalon until
then.  This is to prevent version incompatibility problems, and hopefully
motivate Avalon to a release (I can always dream, can't I?).

So, my vote is as Remy originally stated - keep this in 4.1; drop it for
now from 4.0.

- Sam Ruby


Mime
View raw message