tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "C. Gaffga" <cgaf...@triplemind.com>
Subject Tomcat 4, JDBCRealm Configuration, Catalina.start: LifecycleException: This Realm has already been started
Date Thu, 22 Feb 2001 17:35:00 GMT
Hi !

(I've mailes this to the user list before, but didn't get answer, so i try
on this list because I think it could by a bur or/and version 4 is more
advanced, so better ask the developpers)

I've installed tomcat 4-beta to check out the filtering mechanism. But I
have some problems to configure the JDBCRealm.
When I start up tomcat i got a exception in logs/catalina.out:

Starting service Tomcat-Standalone
Apache Tomcat/4.0-b1
Catalina.start: LifecycleException:  This Realm has already been started
LifecycleException:  This Realm has already been started
        at org.apache.catalina.realm.JDBCRealm.start(JDBCRealm.java:542)
        at
org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1142)
        at
org.apache.catalina.core.StandardEngine.start(StandardEngine.java:217)
        at
org.apache.catalina.core.StandardService.start(StandardService.java:353)
        at
org.apache.catalina.core.StandardServer.start(StandardServer.java:454)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:654)
        at org.apache.catalina.startup.Catalina.execute(Catalina.java:595)
        at org.apache.catalina.startup.Catalina.process(Catalina.java:176)
        at java.lang.reflect.Method.invoke(Native Method)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:157)

I have the following in my conf/server.xml:

      <Realm
          className="org.apache.catalina.realm.JDBCRealm"
          debug="99"
          driverName="org.gjt.mm.mysql.Driver"

connectionURL="jdbc:mysql://62.208.90.143/urlaubstage?user=urlaubstage;passw
ord=something"
          userTable="user"
          userNameCol="username"
          userCredCol="passwd"
          userRoleTable="user_roles"
          roleNameCol="rolename" />


Please mail me, if you heard of this problem or know how to solve it.
Thanks in advanve.

Christoph Gaffga
cgaffga@triplemind.com




Mime
View raw message