tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: Tomcat 4 Jasper
Date Thu, 28 Dec 2000 23:11:24 GMT
Glenn Nielsen wrote:

> The version of Jasper in Tomcat 4 inherits alot of baggage from
> the original Jasper from 3.x.  Jasper in 3.x had to support
> both jdk 1.1.x and required jdk 1.2 to use the SecurityManager.
>
> Since Jasper in Tomcat 4 implements JSP 1.2, the version of jasper
> in Tomcat 4 is required to use jdk 1.2 or greater, right?
>

Yep.  JSP 1.2 requires Servlet 2.3, which requires JDK 1.2 or later.

>
> So can I remove all the support for jdk 1.1.x from the version
> of jasper in Tomcat 4?
>

Sounds fine by me.

Over the longer term, I would like to see us think about making a smarter Jasper
(i.e. one that generated better-performing code), as well.

>
> Regards,
>
> Glenn
>
>

Craig McClanahan



Mime
View raw message