tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Oschwald" <roschw...@yahoo.com>
Subject TOMCAT 3.2.1 STANDALONE AND SSL: Error reading request
Date Mon, 18 Dec 2000 09:26:53 GMT
Hi,

sorry for my mail into this group, but the user group seems to be dead since the 19th of November
and we got an urgent SSL problem:

I'm currently stuck with my SSL enabling of tomcat 3.2 with a weird error message.
As soon as I try to access SSL secured content, the following error occurs:

2000-12-15 05:23:51 - ContextManager: Error reading request R( /) 400
2000-12-15 05:23:51 - Ctx(  ): 400 R( /) null
2000-12-15 05:23:51 - Ctx(  ): Handler null null
2000-12-15 05:23:51 - Ctx(  ): IOException in: R( /) Socket closed
2000-12-15 05:10:57 - Ctx(  ): IOException in: R( /) Socket closed
 
After a while, the following exception is thrown:

        at java.io.IOException.<init>(IOException.java:49)
        at javax.net.ssl.SSLException.<init>([DashoPro-V1.2-120198])
        at java.io.BufferedInputStream.fill(BufferedInputStream.java:192)
        at javax.servlet.ServletInputStream.readLine(ServletInputStream.java:138)
        at org.apache.tomcat.service.http.HttpRequestAdapter.readNextRequest(HttpR
equestAdapter.java:129)
        at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(
HttpConnectionHandler.java:195)
        at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:41
6)
        at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:4
98)
        at java.lang.Thread.run(Thread.java:498)
 
I've compiled tomcat 3.2 with SSL support (SSLSocketFactory was compiled successfully)
as described in the Tomcal-SSL-Howto document.

Also, I've changed my jdk-1.3 (IBM) jre java.security file as described.

I had a problem adding my CERT to the keystore, where keytool always complained that the 
public keys are different between the stored and given key.
I worked that around by deleting the keystore and let keytool create it during the CERT import.
That worked (But I'm not sure that RSA is enabled when using that way).
The system is SuSE Linux 7.0, jdk: SUN 1.2.2, JSSE 1.0

Has anyone an idea what the problem is? Is this caused by a keystore problem reading my CERT
or is there any hint you can give me?



Thanks in advance!


Robert


Mime
View raw message