tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: Catalina-4M5 question: parameters?
Date Wed, 29 Nov 2000 22:28:19 GMT
Matthew L Daniel wrote:

> If this is not the proper forum to be discussing Catalina related difficulties,
> please advise me and I will take this elsewhere.  As some other kind soul
> reported, BugRat is exactly that.  Even the usage page is broken.
>
> I am using the CVS build of Catalina 4.0M5.  It was updated 15 minutes ago,
> with no changes.  I am using IBM's 1.3 JDK on Linux 2.2.17 i686.
>
> The parameter handling is HORRIBLY broken.  Asking for any valid name results
> in a null value, and asking:
>
> Enumeration params = request.getParameterNames();
> while( params.hasMoreElements() ) {
>     String name = params.nextElement().toString();
>     log("Param("+name+") := "+request.getParameter(name));
> }
>
> results in
>
> Param(/velocity/myservlet?) :=
>
> for any number of parameters passed, regardless of their values.
> Same thing for JSP:
>
> /velocity/test1.jsp?
>
> I wanted to ask if this was a known problem before I tear into the meat of
> Catalina (having only Tomcat 3.2b8 development experience prior).
>

To my knowledge, this is not a known issue.  In fact, I've got tons of stuff
that
depends on request parameters working just fine in 4.0.  I would be very
interested
in a simple test case that can reproduce what you're seeing.

By the way, there is no "milestone 5" yet, despite the announcement of plans to
have one done.  We really want to have a workable connector that people can
test,
and what's in CVS isn't quite there yet.

>
>   Thanks,
>   -- /v\atthew

Craig

Mime
View raw message