tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bond <tb...@mitre.org>
Subject problem deploying J2EE RI-built EAR/WAR file
Date Fri, 17 Nov 2000 21:08:31 GMT
Hi,

I'm trying to get a WAR file created with the J2EE reference
implementation deployment tool to deploy on Tomcat 4.0.  The new
env-entry feature (as of 11/1) is working.  Here's part of my web.xml
file:

<servlet>
    <servlet-name>vlweb</servlet-name>
    <display-name>vlweb</display-name>
    <description>no description</description>
    <jsp-file>/index.jsp</jsp-file>
  </servlet>
  <session-config>
    <session-timeout>30</session-timeout>
  </session-config>
  <env-entry>
    <description>no description</description>
    <env-entry-name>rmiserver</env-entry-name>
    <env-entry-value>tester.mitre.org</env-entry-value>
    <env-entry-type>java.lang.String</env-entry-type>
  </env-entry>

We are having two problems:

1.  If I start the server with just the .war file, two levels of
directories are created (webapps/vltrack/vltrack) instead of one
(webapps/vltrack).

2.  I added a leading '/' to the jsp-file parameter below because
Tomcat threw the following error at startup:

2000-11-17 15:36:42 StandardHost[localhost]: Deploying web application
at context path /vltrack from URL
file:e:\jakarta-tomcat-4.0\webapps\vltrack
2000-11-17 15:36:42 ContextConfig[/vltrack] Configuration error in
application web.xml
java.lang.IllegalArgumentException: JSP file index.jsp does not start
with a / character
 at
org.apache.catalina.core.StandardWrapper.setJspFile(StandardWrapper.java:311)

This WAR deployed on both J2EE RI and Weblogic 5.1 so it seems there
may be a slight bug here.

--- Tim





Mime
View raw message