tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Gentilin <johngli...@eyecatching.com>
Subject Help, Tomcat 3.1 refusing connections
Date Thu, 02 Nov 2000 23:29:05 GMT
I have developed a servlet that receives request by overiding
httpServlet#service() and sends a response. The traffic back
an forth is a small XML formatted block ( < 1K ). To test my
servlet, I have a simple java application that  formats requests
and sends them to the Servlet  through URL Connection. The
connection is directly through Tomcat and not apache. Now
if I run several iterations 20K +, I will get an occasional
exception on the client side stating "Find not found" where
the file specification is the URL I use to attach to my Servlet.
i.e. http://localhost:8080/myServlet.  I also have a custom
URL mapping in my web.xml to call my servlet directly
(not through invoker). There are no errors in my Tomcat
log files.

During the test if I run netstat -a . I see several connections
in the Fin_Wait2 state. (700+ My unit test does not test for
concurrency and only issues sequential requests.

I have seen  notes on this through Apache with a Fin_Wait2
issue with Apache Server. It states that this is just as much
an operating system problem as it is the Web Server. The
Web Server has a work around and I was wondering if this
problem has shown up on anyone else's Tomcat
Configuration and what they might of done about it.

Any help would be greatly appreciated.

TIA
John G

Configuration:
Tomcat 3.1 Final
Sun JDK 1.2.2
Xerces 1_2_1
Redhat 6.2 ( PII 700, 128 MB Ram)




Mime
View raw message