tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paulo Gaspar" <paulo.gas...@krankikom.de>
Subject mod_jk: getting EAPI warnings all the time (even after compiled with -DEAPI)
Date Fri, 22 Sep 2000 02:23:35 GMT
I have an Apache running on Windows NT with SSL.

Every time I load mod_jk I get the infamous warning:
  "[warn] Loaded DSO modules/mod_jk.dll uses plain Apache 1.3 API,
   this module might crash under EAPI! (please recompile it with -DEAPI)"

I downloaded the sources, downloaded Apache, added the necessary:
  /D "EAPI"
to the "mod_jk.dsp" Visual C make file and... I still get the damn 
warning!

I only compiled Apache to get the ApacheCore.lib, but I am NOT using that
version.


Where did I go wrong?
Is it safe to ignore the warning?
Is it safe to ignore the warning when using SSL?

Is it something wrong with the Apache version I used to compile the 
mod_jk? (The basic download of "apache_1.3.12" from www.apache.org)


I am using Tomcat 3.2b4 and used the Visual C make file version in
the src\native\apache1.3 directory.


Thanks for your attention,
Paulo

Mime
View raw message