tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jones" <kev...@develop.com>
Subject Garbage is response stream
Date Thu, 14 Sep 2000 11:54:06 GMT
I'm not sure where to report this but here seems as good a place as any.

I'm using Tomcat (3.2b3 approx) with Apache and ajpv12 (I think - this is
what is in my tomcat.conf file). This is on Win2K and the
ApacheModuleJServ.dll I'm using is dated 31st July 2000.

If I use Tomcat stand-alone then I have no problem, but if I use Tomcat with
Apache I get garbage in the output stream. An example, I have a JSP page
that produces XML (but the problem is there for any response type), if I go
direct to Tomcat (on 8080) then I get this -

HTTP/1.0 200 OK
Content-Type: text/xml
Servlet-Engine: Tomcat Web Server/3.2 beta 3 (JSP 1.1; Servlet 2.2; Java
1.3.0; Windows 2000 5.0 x86; java.vendor=Sun Microsystems Inc.)

<?xml version="1.0" ?>
<phoneentries>
<entry>
    <name>Don Box</name>
    <number>555-2137</number>
</entry>
etc...

If I use Tomcat/Apache I get this

HTTP/1.1 200 OK
Date: Thu, 14 Sep 2000 11:41:15 GMT
Server: Apache/1.3.12 (Win32) tomcat/1.0 Servlet-Engine: Tomcat Web
Server/3.2 beta 3 (JSP 1.1; Servlet 2.2; Java 1.3.0; Windows 2000 5.0 x86;
java.vendor=Sun Microsystems Inc.)
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/xml

13b
<?xml version="1.0" ?>
<phoneentries>
<entry>
<name>Don Box</name>
<number>555-2137</number>
</entry>

etc

Notice the 13b at the start of the response body - this number is random,
but some value is always there.

So - is this s known problem that has been fixed in the latest version of
the connector? or is it a bug that I should report via BugTrack?

Thanks,

Kevin Jones
DevelopMentor
www.develop.com


Mime
View raw message