tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "O'Hagan, Shaun" <soha...@tanning.com>
Subject jbuilder failing to debug tomcat 4.0-m1
Date Fri, 29 Sep 2000 15:00:00 GMT

Hi,
Sorry second question of the day !

I'm trying to strap tomcat/catalina into Jbuilder 3.0 in order to debug my
security problems.  I've written a small piece of java that attempts to call
:

org.apache.catalina.startup.Bootstrap.main( args );

however the jbuilder java compiler generates the following error :

Error : (16) cannot access class org.apache.catalina.startup.Bootstrap;
class file has wrong version 46.0

I extracted Bootstrap.class from the catalina.jar file and analysed it with
some java code.  indeed the major and minor version numbers are 46 and 0.
I've analysed the numbers in other classes built with my java 1.2.2-6
compiler and they have version numbers of 45.3 and not 46.0.  Therefore it
appears that my ant build of tomcat 4.0-m1 is setting up a different version
number.  Any idea where and can I change it to 45.3 ?

Thanks for any insight.

Regards,

Shaun O'Hagan

Tanning Technology Europe

Mime
View raw message