tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: Has anyone run Tomcat in JDK 1.4?
Date Tue, 12 Sep 2000 22:03:19 GMT
"David R. Smith" wrote:

> Hi all,
> I'm trying to run Tomcat 3.1 under JDK 1.4 beta.  So far, no luck.
> Right after Tomcat starts, it stops with a classdef not found error,
> claiming that it can't find com.sun.xml.parser.Parser  (which is
> there, in xml.jar, and it's in the classpath).
>
> This is a Tomcat installation that runs just fine in JDK 1.3, on NT.
> But if I tweak the tomcat.bat file to use JDK 1.4, it halts with
> the classdef not found error.
>
> Anyone have any tips on working around this problem?
> Or for that matter, can anyone simply say whether they've
> gotten Tomcat to work with 1.4?
>

I haven't tried 1.4, but I would suggest you experiment with 3.2 instead
of 3.1.  The reason is that 3.2 can use any JAXP-compatible XML parser.
If memory servers me, doesn't 1.4 have a JAXP-compatible parser built
in?  If so, it could be interfering with the old parser (in xml.jar) that
Tomcat 3.1 used.

>
> Thanks in advance
> Dave
>

Craig McClanahan

====================
See you at ApacheCon Europe <http://www.apachecon.com>!
Session VS01 (23-Oct 13h00-17h00):  Sun Technical Briefing
Session T06  (24-Oct 14h00-15h00):  Migrating Apache JServ
                                    Applications to Tomcat



Mime
View raw message