tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BugRat Mail System <tomcat-b...@cortexity.com>
Subject BugRat Report #120 has been filed.
Date Fri, 15 Sep 2000 04:38:37 GMT
Bug report #120 has just been filed.

You can view the report at the following URL:

   <http://znutar.cortexity.com:8888/BugRatViewer/ShowReport/120>

REPORT #120 Details.

Project: Tomcat
Category: Bug Report
SubCategory: New Bug Report
Class: swbug
State: received
Priority: high
Severity: critical
Confidence: public
Environment: 
   Release: 3.1
   JVM Release: 1.2.2_005
   Operating System: Linux
   OS Release: Red Hat 6.2
   Platform: Intel

Synopsis: 
Different servlet w.r.t. pathInfo behavior w/ & w/o Apache

Description:
The information being passed into a Servlet is different if 
it is invoked through Apache or not.  I have a servlet which
saves an address (based upon a form) which I have registered
in web.xml as follows:
<servlet-mapping><servlet-name>SaveAddress</servlet-name>
<url-mapping>/save/ADDRESS/*</url-pattern></servlet-mapping>

When I hit "localhost:8080/save/ADDRESS" which goes against
tomcat directly, I get the following (from debugging statements)
Path Info: null
Servlet Path: /save/ADDRESS

When I hit "localhost:80/save/ADDRESS" which goes via apache 
(and mod_jserv.so), I get the following:
Path Info: /ADDRESS
Servlet Path: /save/ADDRESS

As you can see, the servlet path is the same, but the Path 
Info is coming back different.

Mime
View raw message